Jump to content


Hello, newvbie here. :)


I've been following  the excellent tutorial listed on the website and have trawled through the forum for an answer to my problem but can't seem to find an solution.

I've got everything working fine via the push to talk but cannot for the life of me get the hotword started.

As per the tutorial I tried 

googlesamples-assistant-hotword --device-model-id abcd

All I get back is "Illegal Instruction"

I then tried:

googlesamples-assistant-hotword --device-model-id <your device id>

With the correct device id added and again "Illegal Instruction"

I finally tried:

googlesamples-assistant-hotword --device-model-id <your device id> --project-id <your project id>

Again with the correct values added and yet again "Illegal Instruction"

If anyone could help me get past this little hurdle, I'd be eternally grateful.

Thanks in advance.


Share this post

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
59 minutes ago, Gus said:

Are you running this on a Raspberry Pi zero? Just browsing through some Github issues there may be an issue with the hotword service starting correctly. Typically erroring with "illegal instruction". 

This Github topic may have a solution: https://github.com/googlesamples/assistant-sdk-python/issues/235 

I will need to look into this more and test.

Many thanks for your reply, it's not a Zero it's a B+ V1.2 running the latest Raspbian Stretch.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now